If you were linked to this page from your WordPress dashboard, then it means that you’re running an outdated version of PHP.
PHP is the programming language that WordPress and OptinMonster are built on. The version that is currently used for your site is either insecure or no longer supported.
Newer versions of PHP are both faster and more secure. In fact, the version of PHP your website is using no longer receives security updates, which is why we sent you the notice.
The easiest way to resolve this issue is to contact your web hosting provider and ask them to update the PHP version on your hosting account. This actually is quite easy, and something they should be doing proactively. However if your web hosting company is unwilling to do this, then it clearly shows that they DO NOT care about your website security.
In that case, we recommend that you switch to one of the recommended WordPress hosting companies listed on WPBeginner’s article.
In case your web hosting companies ask, below are the PHP version requirements for the OptinMonster plugin.
Although you should have your web hosting company update your PHP version 7.3 or greater, OptinMonster currently works on any PHP version 5.5 or higher (WordPress itself requires PHP 5.6+ for the latest updates).
Support for PHP 5.5 will be discontinued in 2020.
Frequently Asked Questions
Which version should I update?
You should update your PHP version to 7.3 or greater (whatever the latest version is that is offered by your web host). Most sites can upgrade to PHP 7+ without issues, which is our recommendation.
How do I update?
Web hosts have the ability to update your PHP version. In most cases you can upgrade within your web hosting control panel or by submitting a support ticket to your host.